Skip to Content

.NET

處理 TWAMPd 的 Apache 無法啟動問題

稍早因其他程式需求,開啟了 .NET 3.5,結果後來使用 TWAMPd 時,發現 Apache Web Server 無法啟動,查詢一些資料,大多說明是 Windows 內定的 Web Server 要關閉,但我只用 Win10 內定程式,沒有特別去開啟 Web Server(Win10 還是用 IIS 嗎?),因此懷疑和 .NET 3.5 有關.

於是去查看 Windows 相關功能.

在控制台 -> 程式集 -> 程式和功能 -> 開啟或關閉 Windows 功能

image

 

安裝程式被要求安裝 .NET 3.5 的問題

在安裝一些程式時,被要求要 .NET 3.5,但我的系統是 Win10,也有安裝更高版本的 .NET 了,想不到還會需要舊的版本.看來 .NET 的並沒有完全向前相容嘛.

寫這篇是因為當初不知道需要安裝舊版的,以為是出了什麼錯,結果找到啟用 .NET 3.5 的方法,就記錄下來了.

在控制台 -> 程式集 -> 程式和功能 -> 開啟或關閉 Windows 功能 -> 勾選「.NET Framework 3.5」,再依著要求操作即可.

image

 

訂閱文章


about seo